Darstellungsfehler mit Flash und Firefox 4 in OpenSuSE (x64)

Seit längerer Zeit, genauer gesagt seit dem Update auf Firefox 4 ärgere ich mit damit rum, dass Seiten mit Flash-Inhalten fast immer falsch dargestellt werden. Oft werden nur Teile dargestellt – hier ein Beispiel:

Nach etwas Googlen hab ich herausgefunden, dass das wohl kein Unbekanntes Problem beim Gespann Firefox, Flash und 64bit ist.

Problem ist: Für die Linux 64bit Architektur hat Adobe es bis heute nicht geschafft, eine offizielle Version von Flash raus zu bringen. Es gibt zwar Beta-Versionen, wenn man die aber nutzt, verwendet man eine Aßbach alte Version der Flash-Implementierung und der Rechner „supported“ alle Sicherheitslücken, die seit dem Release entdeckt wurden.

Um doch irgendwie 32bit Flash mit einem 64bit Browser nutzen zu können, gibt es eine Erweiterung namens nspluginwrapper. Die sorgt dafür, das 32bit Plugins im 64bit Browser funktionieren. Und genau hier ist wohl auch das Problem für die Darstellungsfehler zu suchen.

Mein pragmatischer Ansatz war hier erst mal, eine aktuelle Version einzuspielen. Da es so direkt keine aktuelle Version als fertiges RPM für OpenSuSE 11.3 64bit gibt, hab ich „mal eben schnell“ eine eigene mit hilfe des OpenSuSE Build Services gebaut, die es hier zu finden gibt.

Bis dato läuft jetzt alles recht stabil. So sieht es übrigens „gut“ aus:

Zur Installation:

  1. Zuerst die derzeit installierte Version vom nspluginwrapper via Yast oder zypper deinstallieren
  2. Repository hinzufügen mit zypper ar <url> (url = OpenSuSE 11.3 / OpenSuSE 11.4)
  3. zypper ref und zypper up ausführen und Updates installieren
  4. Done!

Das könnte Dich auch interessieren...

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.